Maintenance Downtime

Completed
Scheduled for February 25, 2022 at 4:00 AM – 5:13 AM

Affects

Dashboard
Mobile App
API
Updates
  • Completed
    February 25, 2022 at 5:13 AM
    Completed
    February 25, 2022 at 5:13 AM

    Maintenance has completed successfully.

  • In progress
    February 25, 2022 at 4:00 AM
    In progress
    February 25, 2022 at 4:00 AM

    Maintenance is now in progress.

  • Planned
    February 25, 2022 at 4:00 AM
    Planned
    February 25, 2022 at 4:00 AM

    The entire ServiceBell platform will be unavailable during maintenance. The ServiceBell widget will not be visible and your site visitors should experience no disruption aside from being unable to see the widget.